ホーム > ガイド > CalibreのDRMプラグインを更新

DeDRMプラグインがCalibre 5に対応できない

calibre syntaxエラー

Calibreを5.0(またはそれ以降)にアップグレードしましたが、DeDRMプラグインが機能しなくなったことがわかりました。 V4.xからのアップデート後、プラグインリストに表示されません。また、DeDRMプラグインをCalibreにインストールすることもできません。プラグインを読み込もうとすると、SyntaxError:無効な構文(calibre_plugins.dedrm.init、168行目)が表示されました。DeDRMプラグインはCalibre5.Xでは機能しませんか?

2020年9月25日、Calibreは新しいバージョン5.0.1をリリースしました。 それ以来、多くの人がDeDRMプラグインをCalibre5.0以降のバージョンにインストールできないと報告しました。DeDRMプラグイン(他のいくつかのプラグインを含む)が機能しない理由は、DeDRMプラグインがまだPython 2を使用しているのに、Python 2が今年廃止されたため、Calibre 5.xがPython3の使用に移行したためです。 Calibreの最新バージョンとは互換性がありません。

解決方法1. 最新バージョンのDeDRMプラグインをCalibre5.xにインストール

最近、DeDRMプラグインがPython3を使うCalibre5.xで動作するように更新されています。これで、最新バージョンのDeDRMプラグインV7.1.0をCalibre5.xに正常にインストールできます。

1 最初にCalibre(5.0以降のバージョン)をコンピューターにインストールします。

2 DeDRM_tools_7.1.0.zipをダウンロードします。

ファイルを解凍すると、DeDRM_plugin.zipファイルが表示されます。

3 DeDRM_plugin.zipをCalibre5.xに追加します。

放截图放截图放截图

calibre 5 dedrm

ステップ2. Calibre5.xを古いバージョン4.xにダウングレード

DeDRMプラグインはCalibreの古いバージョンでうまく機能するため、Calibreを最新バージョン5.xから古いバージョン4.x(たとえば、Calibre 4.23)にダウングレードすることでこの問題を解決することもできます。

1 Calibre 5をアンインストールします。

2 Calibre 4をインストールします。

Calibreの古いバージョン4.xをダウンロードして、コンピューターにインストールします。

3 DeDRM_tools_6.8.1.zipをダウンロードします。

DeDRM_tools_6.8.1.zipをコンピューターにダウンロードして解凍します。

4 DeDRM_pluginを古いバージョンのCalibreに追加。

calibre 4 dedrm

解決方法3. Epubor Ultimateの試用(DeDRMプラグインをインストールせず)

Epubor Ultimateは、Kindle、Kobo、Google Play、Nookの電子書籍ストアからの電子書籍の復号化と変換で有名なブランドです。Calibreと比較すると、非常にシンプルなインターフェイスではるかに簡単に使用できます。

remove-drm-from-kindlepc

最も重要なことは、電子書籍のDRMを削除するためにプラグインをインストールする必要がないことです。パソコンにダウンロードされた完了の電子書籍をEpubor Ultimateにドラッグ・ドロップするだけで、DRMは自動的に削除されます。これは、DeDRMプラグインがCalibreで機能しない問題を修正するのに役立つ非常に強力な代替ツールです。